1. 首页
  2. 科技数码

家用服务器篇之计算节点

创作立场声明:本文不含任何硬件设备购买渠道及软件许可下载链接。233

简单分享一个家用服务器(计算节点)在异地环境下的部署方案。

异地部署理由

1、服务器需要稳定的动力环境

2、服务器运转时产生的噪音放在家中难以忍受

3、设备体积较大,占空间

4、对于计算节点来说对带宽、延迟要求并不算太高

5、可以保证稳定的上行带宽

6、省电。。。

搭建思路及过程

一、设备选型:

对于家用计算节点,目前我的应用需求在虚拟化KVM及小规模的集成环境测试,不需要太多的存储资源,但是对内存及CPU线程的要求较高,综合考虑下来选择 lenovo ThinkSystem SR650 系列机架式服务器,配置如下:

CPU及内存CPU及内存

存储存储

网络网络

二、放置位置:

暂时托管在北京某IDC机房,出口带宽100Mbit/sec,联通运营商。(由于本人深处偏远小山沟 延迟100以下完全不敏感 233)

运营商运营商

延迟测试延迟测试

三、异地网络环境搭建:

建立虚拟交换机(vswitch),绑定上行链路;划分port-group(对应交换机相应的业务vlan及管理vlan);划分vmkernal接口并且添加管理地址及缺省网关(对应交换机SVI接口及default-gateway);

vmnetwork拓扑vmnetwork拓扑

建立虚拟网关IDC.bj,刷入配置。(此处不需要网关设备上有公有地址,互联网可达就行。)

创建虚拟网关创建虚拟网关

刷入配置:

hostname idc

logging console notifications

ip name-server 180.76.76.76 219.141.136.10 114.114.114.114

ip domain name bj

login on-success log

username xxx privilege 15 password 7 104F5F4Bx34F4B5D5A537A7E

username xxx privilege 15 password 7 08105D1F5C4Fx4424B585855

lldp run

cdp run

crypto isakmp policy 10

encr 3des

hash md5

authentication pre-share

group 14

crypto isakmp key xxxx address 0.0.0.0

crypto ipsec transform-set TS esp-3des esp-md5-hmac

mode tunnel

crypto ipsec profile PR

set transform-set TS

interface Tunnel0

description to zouxinquan-home

ip address 192.168.255.3 255.255.255.248

no ip redirects

ip mtu 1400

ip nat inside

ip nhrp network-id 1

ip nhrp nhs 192.168.255.2 nbma xxxx.f3322.net multicast

ip nhrp nhs 192.168.255.1 nbma xxxx.f3322.net multicast

ip tcp adjust-mss 1300

cdp enable

tunnel source GigabitEthernet1

tunnel mode gre multipoint

tunnel protection ipsec profile PR

interface GigabitEthernet1

ip address 192.168.78.203 255.255.254.0

ip nat outside

router bgp 64512

bgp router-id 192.168.255.3

bgp log-neighbor-changes

bgp graceful-restart

no bgp default ipv4-unicast

neighbor 192.168.255.1 remote-as 64512

neighbor 192.168.255.2 remote-as 64512

address-family ipv4

network 192.168.16.0 mask 255.255.252.0

redistribute static route-map RES

neighbor 192.168.255.1 activate

neighbor 192.168.255.2 activate

exit-address-family

ip http server

ip http authentication local

ip http secure-server

ip nat inside source static tcp 192.168.2.100 8118 interface GigabitEthernet1 8118

ip nat inside source static tcp 192.168.100.189 5000 interface GigabitEthernet1 5000

ip nat inside source list 1 interface GigabitEthernet1 overload

ip dns server

ip route 0.0.0.0 0.0.0.0 GigabitEthernet1 192.168.78.1

ip route 192.168.16.0 255.255.252.0 GigabitEthernet1 192.168.78.1

ip route 192.168.78.1 255.255.255.255 GigabitEthernet1

ip route 192.168.78.202 255.255.255.255 GigabitEthernet1

ip route 192.168.78.206 255.255.255.255 GigabitEthernet1

ip ssh version 2

ip prefix-list RES seq 5 permit 192.168.78.0/23 ge 32

access-list 1 deny 192.168.78.0 0.0.0.255

access-list 1 permit 192.168.0.0 0.0.255.255

route-map RES permit 10

match ip address prefix-list RES

snmp-server community idc@bj RW

snmp-server location Beijing China

line vty 0 4

transport input telnet ssh

end

在家中的软路由上检查连通性情况:

到服务器延迟稳定到服务器延迟稳定

使用感受

部署一台Ubuntu,一台Windows10在服务器中,目前运行状态良好,性能满足个人需求。

UbuntuUbuntu

终于不爆内存了终于不爆内存了

总结

对于家庭有相当一部分计算需求并且对延迟及带宽没有太大需求的值友,可以考虑一下参考下我这样的异地部署方案哈

原创文章,作者:夜风博客,如若转载,请注明出处:https://www.homedt.net/48104.html