1. 首页
  2. 科技数码

QNAP x86 机型 docker 安装 openwrt

写在前面:本文不是给入门级小白看的,所以很多简单的东西请你直接百度了

前提

在qnap上打开ssh, 登录上ssh

输入

ip addr

找到你当前设备的ip, 查看该ip所属的端口,如下图:

QNAP x86 机型 docker 安装 openwrt

ip 192.168.50.55就是在端口eth0上的。如果你的ip是绑定在eth开头的端口上,请继续往下看,如果是br, qvs或者其他的开头你按照下文操作,会出现o插件无效的问题!P.S.这种其实有更简单的设置方法,但是暂时不想写,后面有时间补上吧。

预设

为了方便理解,我这边预设条件,你可以把这里的中括号中的内容替换为你自己实际的

假设你的nas ip 是[192.168.123.18]

则你的路由器网段是[192.168.123.0]

则你的路由器地址为[192.168.123.1]

你希望通过使用没有被占用的ip地址 [192.168.123.100]来访问你新搭建的openwrt

第一步 创建macvlan网络

ssh执行命令:

docker network create -d macvlan --subnet=192.168.123.0/24 --gateway=192.168.123.1 -o parent=eth0 macnet

需要注意的地方:

192.168.123.0 -> 修改为你自己网络所在的网段,比如你nas的ip 是192.168.123.18 那这里就修改为192.168.123.0 (最后一位是0)

192.168.123.1 -> 修改为你路由器的ip地址 比如你nas的ip 是192.168.123.18 那这里就修改为192.168.123.1 (最后一位是1)

eth0 -> 修改为你在第一步中看到的接口,注意必须是eth开头!

你可以通过下面命令查看你的macnet网络是否创建成功

docker network ls

第二步 创建openwrt容器命令

ssh执行命令:

docker run --restart always --name myop -d --network macnet --ip x.x.x.x --privileged sulinggg/openwrt:x86_64 /sbin/init

需要注意的地方:

x.x.x.x 修改为一个你内网中没有被使用的ip, 根据预设条件

这边的x.x.x.x 就修改为192.168.123.100

第三步 修改配置文件

进入容器内部,ssh执行

docker exec -it myop bash

1. 修改openwrt 配置文件,ssh执行

nano /etc/config/network

找到下面一段进行修改

config interface 'lan'

option ifname 'eth0'

option proto 'static'

option netmask '255.255.255.0'

option ip6assign '60'

option ipaddr '192.168.123.2'

option gateway '192.168.123.1'

option dns '192.168.123.1'

eth0 -> 不要改

192.168.123.2 -> 修改为一个你内网中没有被使用的ip, 根据预设条件 这边的就修改为192.168.123.100

192.168.123.1(两处都要改) -> 修改为你路由器的ip地址 根据预设条件 这边的就修改为 192.168.123.1 (最后一位是1)

输入crtl + x 然后 按y回车保存修改(如果你修改错了,或者不想修改,按n回车)

2. 修改防火墙配置文件

ssh执行

nano /etc/config/firewall

option syn_flood '0'

option input 'ACCEPT'

option output 'ACCEPT'

option forward 'ACCEPT'

option flow_offloading '0'

option flow_offloading_hw '0'

option fullcone '0'

这里主要修改 syn_flood 为 '0'

option forward 为 'ACCEPT'

输入crtl + x 然后 按y回车保存修改(如果你修改错了,或者不想修改,按n回车)

输入命令退出容器

exit

重启容器

docker restart myop

进入你的op首页:

http://192.168.123.100

用户名:root

密码: password

QNAP x86 机型 docker 安装 openwrt

手动指定网关

将你的设备(电脑或者手机)的网关和dns设置为你的op所在的地址,这里根据预设就是

192.168.123.100

安卓:

QNAP x86 机型 docker 安装 openwrt

需要在安卓的 WIFI 设置内将 IP 获取方式更改为“静态”或“手动”,其中:

“IP 地址”项目需要更改为网段内不冲突的地址;

“网关”或“路由器”项目需要更改为旁路网关 IP 地址;

“前缀长度”项目填写“24”;

“DNS”项目需要更改为旁路网关 IP 地址(两个 DNS 输入框填写一个就可以)。

完成并提交设置后,关闭 WIFI 开关再打开,连接设置的 WIFI 热点,若当前网络参数为设定值,则证明设置成功。

IOS类似

Windows:

QNAP x86 机型 docker 安装 openwrt

在无线热点的“属性”界面下,点击 “IP 设置 - 编辑”按钮,在弹出框中更改 IP 分配模式为“手动”,打开 IPV4 的开关,根据所处网段及上文安卓的相关设置填写相关参数即可。

Enjoy!

作者声明本文无利益相关,欢迎值友理性交流,和谐讨论~

原创文章,作者:夜风博客,如若转载,请注明出处:https://www.homedt.net/47548.html